Chrysler Voyager & Town & Country The first and foremost name in minivans leading the class since their inception in the 1980s

Rear upper vents not working, lower vents ok

  #1  
Old 08-13-2009, 07:16 PM
Junior Member
Thread Starter
Join Date: Aug 2009
Posts: 2
Default Rear upper vents not working, lower vents ok

In my 2001 T&C, the rear upper vents put out very little air (practically none), when set on the cool setting. I can hear the fan blowing, just no air is coming out. If I turn the **** to heat, I get air out of the lower vents. Any suggestions?

On a side note, my A/C in general is messed up. The compressor is making a terrible clanging noise and I plan to replace it this weekend. I tested the rear air with A/C on and off, still no air.

Thanks.
 
  #2  
Old 09-14-2009, 07:40 PM
Junior Member
Thread Starter
Join Date: Aug 2009
Posts: 2
Default

Fixed. The duct work in the rear of the van is only held together with pressure. In other words, no screws or clips. The duct going from the blower motor the ceiling duct came loose. I tightened up the fit, put a couple screws in it, and I am back in business.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
4everrunning
Chrysler Voyager & Town & Country
2
06-04-2019 11:30 AM
bargainstyle
Chrysler 200 & Sebring
9
06-27-2011 09:04 AM
mwstant
Chrysler 200 & Sebring
2
05-21-2010 08:31 PM
BARCLAY
Chrysler Voyager & Town & Country
0
05-19-2010 04:57 PM
The BIG STEAK
Cirrus & Breeze
1
04-02-2008 03:08 PM


Thread Tools
Search this Thread
Quick Reply: Rear upper vents not working, lower vents ok


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.