Bad PCM?

  #1  
Old 02-25-2010, 04:48 PM
Junior Member
Thread Starter
Join Date: Feb 2010
Location: Pennsylvania
Posts: 16
Default Bad PCM?

My Chrysler Cirrus Lx will not start.
I'm thinking that its the PCM. when i turn the car on the check engine light dose not come on, but all the other light will.
I have checked "automatic shut down relay" and the PCM is not giving it ground.
Also none of sensors are getting a supply voltage.
2 to 3 days before the car stop working most of the sensors stop working.
Could this be the PCM or something else?
 
  #2  
Old 02-25-2010, 10:24 PM
CHRYSLER TECH's Avatar
Super Moderator
Join Date: Mar 2006
Location: Norcross GA
Posts: 8,115
Default

check power and ground to the PCM first
 
  #3  
Old 02-26-2010, 04:37 AM
Junior Member
Thread Starter
Join Date: Feb 2010
Location: Pennsylvania
Posts: 16
Default

Yeah its getting power.
 
  #4  
Old 02-26-2010, 06:20 AM
CHRYSLER TECH's Avatar
Super Moderator
Join Date: Mar 2006
Location: Norcross GA
Posts: 8,115
Default

bad pcm
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ruger1944
Chrysler Voyager & Town & Country
10
03-25-2015 03:14 PM
abj63
Chrysler Voyager & Town & Country
7
04-12-2011 04:09 PM
BIGCJ
Cirrus & Breeze
20
05-27-2010 05:24 AM
moorek
Chrysler Voyager & Town & Country
0
08-23-2009 07:28 PM
pigcop
300M, Concorde, LHS, New Yorker
1
02-12-2007 01:50 AM


Thread Tools
Search this Thread
Quick Reply: Bad PCM?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.