Forum Issues Need help with Chrysler Forum? Ask. Have a suggestion to better Chrysler Forum? Tell us here.

My Sebring will not start after maintenance

  #1  
Old 01-06-2008, 07:48 PM
Thread Starter
Join Date: Jan 2008
Posts: 1
Default My Sebring will not start after maintenance

Hi...

I need your help! I just replaced a leaking oil sending unit on my 2000 Sebring JXi convt. and now It will not start! Not only that it will not even turn over. All electrical equipment seem to work fine including the headlights. Also...I changed out the transmission solenoid the day before but I had no problems with starting up. I test drove after replacing and had no problems so I don't know if the problem is this repair or the oil pressure switch. Any suggestions? Btw...this is my first Chrysler auto so I am at a loss. Thanks!!

Mike B
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
p8ntballnxj
Chrysler 200 & Sebring
2
02-05-2012 07:23 PM
sidearm17
General Tech
7
12-08-2008 09:31 PM
BenjaminA
Chrysler Pacifica
5
07-02-2007 08:51 PM
cardinal5
Chrysler Voyager & Town & Country
1
06-06-2007 03:32 PM
Midnight 85
Off Topic
0
03-24-2006 05:35 PM


Thread Tools
Search this Thread
Quick Reply: My Sebring will not start after maintenance


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.