Forum Issues Need help with Chrysler Forum? Ask. Have a suggestion to better Chrysler Forum? Tell us here.

Poor Starting in cold weather 2006 Voyager CRD

  #1  
Old 05-03-2018, 01:52 PM
Junior Member
Thread Starter
Join Date: May 2018
Posts: 4
Default Poor Starting in cold weather 2006 Voyager CRD

Hi
I am new to this, hopefully I am placing my post in the correct area!
Ok, here is my issue, first, details of the car - 2006 Chrysler Voyager 2.8 CRD LX Auto
Problem: When the weather was very cold (-14 C here in Hungary) the car struggled to start with masses of black smoke out of the exhaust, now that the weather is generally 28 - 30 deg it starts first time every time
Diagnostics: I checked the IPM Unit and found that F17 (20A) was O/C, I replaced this and immediately blew once I started the engine, I managed to find a part manual on the web and discovered that the fuse feeds the fuel heater relay (all beginning to make sense). I removed the fuel heater relay, replaced the fuse and sure enough this time the fuse did not blow. I measured the resistance between relay pin 30 and deck which gave me a reading of 0.2 ohms, hence the blowing of the fuse and the problem being either the fuel heater unit or the wiring loom. (although on one site I looked at it was mentioned that it could be the crank case Ventilation heater, does my model have one?)
Has anyone else experienced this same issue and did it turn out to be what I suspect, any help would be much appreciated.
Basic question but where is the fuel filter/Water separator/fuel heater unit on my model as I have read conflicting reports on this and if it does turn out to be the fuel heater unit does anyone have the part number for it and where can I get one apart from Chrysler which my understanding is that they are not very helpful.
Lastly, how difficult is it to replace this unit within the fuel filter/water separator, I have worked on older cars in my youth but as we all know modern cars are somewhat mind blowing!

Any input would be much appreciated

Eddy
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mr. yuck
General Tech
4
12-29-2017 11:13 AM
bluefish001
Chrysler 300, 300C & 300C SRT-8
5
04-17-2014 06:31 AM
nottmtrucker
Chrysler Voyager & Town & Country
10
06-23-2013 07:05 PM
msarles1
Chrysler Pacifica
2
02-14-2011 07:28 AM
chcjbilik
Chrysler 200 & Sebring
1
12-07-2007 04:28 PM


Thread Tools
Search this Thread
Quick Reply: Poor Starting in cold weather 2006 Voyager CRD


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.