General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

2009 Dodge Charger throttle light

  #1  
Old 04-29-2019, 10:37 PM
Junior Member
Thread Starter
Join Date: Apr 2019
Posts: 3
Default 2009 Dodge Charger throttle light

A few weeks ago my check engine light and throttle control light came on after driving for about 10 minutes, at the same time my temperature gauge was all the way down on C like on a cold start (it should have moved up at least a quarter of the way by that time). Right away i pulled over and reset the throttle sensor and the throttle light shut off and temp gauge went back to normal, after driving for a bit longer the check engine light shut off.
Everything seemed fine.

a few days later this happened again. same process but i took the car to have the code read. it read for a cooling issue. I added coolant hoping that was the problem and the light went off faster this time.
the same issue happened today... twice. it seems to be repeating faster. Im not having any issue with throttle control, it seems to be working normally. (no shaking or uncontrolled accel or decel) but im wondering why the light would come on during a cooling code.
 
  #2  
Old 04-29-2019, 10:38 PM
Junior Member
Thread Starter
Join Date: Apr 2019
Posts: 3
Default

also for reference i have the 2.7L V6
 
  #3  
Old 04-30-2019, 06:01 AM
Senior Member
Join Date: Jul 2017
Location: Western NY
Posts: 811
Default

How much coolant did you have to add? The temp Gage and warning light and CEL denotes that the ECT sensor had nothing to read from due to lack of coolant, and will turn on those lights accordingly and driven far enough will put the car in limp mode.
Check for coolant leaks and repair as needed (hoses, fittings,possible heater core leak,thermostat, radiator,cap and possible water pump). The 2.7 is a bit of a pain for some coolant issues and a real nasty for water pump...but it is what it is as far as design and one has to deal with it as such...sorry no magic wand with these motors.
 

Last edited by REBEL59; 04-30-2019 at 06:46 AM.
  #4  
Old 04-30-2019, 10:11 AM
Junior Member
Thread Starter
Join Date: Apr 2019
Posts: 3
Default

I added up to the full line at cold in the morning after it at all night. Just checked this morning and itís back really low I think I have a coolant leak which is making more sense. Taking it in now to have my mechanic find the leak.
Originally Posted by REBEL59 View Post
How much coolant did you have to add? The temp Gage and warning light and CEL denotes that the ECT sensor had nothing to read from due to lack of coolant, and will turn on those lights accordingly and driven far enough will put the car in limp mode.
Check for coolant leaks and repair as needed (hoses, fittings,possible heater core leak,thermostat, radiator,cap and possible water pump). The 2.7 is a bit of a pain for some coolant issues and a real nasty for water pump...but it is what it is as far as design and one has to deal with it as such...sorry no magic wand with these motors.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Rockape652
General Tech
0
11-08-2018 07:44 PM
RacingJunk
Classified Feed
0
10-25-2013 04:18 PM
profbob
Chrysler Pacifica
8
11-04-2010 07:32 AM
chargerlady
PRIVATE For Sale / Trade Classifieds
1
12-31-2006 12:19 AM
Midnight 85
Brand News, Concepts & Rumors
0
03-02-2006 02:44 PM


Thread Tools
Search this Thread
Quick Reply: 2009 Dodge Charger throttle light


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.