Won't start - Chrysler Forum - Chrysler Enthusiast Forums


General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 03-21-2018, 09:43 PM
Junior Member
Thread Starter
 
Join Date: Mar 2018
Location: Gippsland
Posts: 2
Default Won't start

Hello. I have a 2012 300c. It had a flat battery from not being used. The battery was charged but the car will not start. Everything else works and it will go to acc but won't start. Otsshowing a red lightning bolt and a check engine light in the dash. Does anyone know what could be the issue. Thanks
Reply With Quote
  #2  
Old 03-22-2018, 02:51 PM
Senior Member
 
Join Date: Mar 2018
Posts: 136
Default

After the battery was recharged, did you try disconnecting the battery to clear those codes?
Reply With Quote
  #3  
Old 03-23-2018, 07:05 AM
Junior Member
Thread Starter
 
Join Date: Mar 2018
Location: Gippsland
Posts: 2
Default

Quote:
Originally Posted by BiliTheAxe View Post
After the battery was recharged, did you try disconnecting the battery to clear those codes?
hey Bill. Yes it was disconnected for a week while I was away. It still wont start.
Reply With Quote
  #4  
Old 03-23-2018, 08:34 AM
Senior Member
 
Join Date: Jul 2017
Location: Western NY
Posts: 476
Default

Is this the ORIGINAL battery at almost 6 years of service? Charged back up or not, it is in need of a load test being done to test the Ca/Cca left in it or a dead cell. AND it probably needs to be replaced if it is the original.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Wipers won't shut off - won't stop in park position skatetrainer Chrysler 200 & Sebring 2 05-12-2014 08:42 AM
Problem with cold start Floods out, won't start jbda Cirrus & Breeze 2 04-01-2013 11:09 AM
05 Cruiser won't start/won't crank 2005Cruiser Chrysler PT Cruiser 18 01-22-2012 05:23 PM
Urgent! Sebring 07 won't start and won't shift laura Chrysler 200 & Sebring 5 04-11-2010 08:48 PM
05 T&C Died & Won't Start chris banks Chrysler Voyager & Town & Country 2 03-09-2006 06:30 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 02:29 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.