New Member Area New to CF? Stop in tell us about you.

2008 4.0 town and country no transmission

  #1  
Old 10-26-2018, 12:52 PM
Junior Member
Thread Starter
Join Date: Oct 2018
Posts: 1
Default 2008 4.0 town and country no transmission

2008 4.0 town and country had code c121c torque request denied. Running on hwy then engine rpm up to 6000. foot off the gas coasted to a stop. Engine runs fin but transmission will not move vehicle in and position. Park will hold ,but no movement of any kind from transmission. ESP light on. Jacked up and no failed axles, transmission made no previous clunking or banging noise of any kid. Transmission fluid level goes down when engine running and selected in fwd or reverse. Erased messages and re ran same problem ,no codes ....
Has anybody run into this and what the fix may be?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
vernd
Chrysler Voyager & Town & Country
14
05-17-2018 09:15 AM
NewTouringOwner2008
Chrysler Voyager & Town & Country
3
10-22-2015 07:22 PM
Chrysler Voyager & Town & Country
1
08-03-2015 12:07 PM
robertway
Chrysler Voyager & Town & Country
4
07-17-2011 01:18 PM
toubis
Chrysler Voyager & Town & Country
6
10-22-2008 06:53 AM


Thread Tools
Search this Thread
Quick Reply: 2008 4.0 town and country no transmission


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.