New Member Area New to CF? Stop in tell us about you.

Timing question

  #1  
Old 07-14-2018, 11:36 PM
Junior Member
Thread Starter
Join Date: Jul 2018
Posts: 1
Default Timing question

Hey all, having issues with a few things.
so I am replacing the water pump in the 04 sebring 2.7l, I have the timing cover off and everything I am suppose to. I found what I thought was the correct links for the chain, and what I thought was the correct Mark's on all the gears, replaced the water pump and timing chain tensioner, and reassembled the timing system and I was verifying before I put the cover back on by rotating the crank manually. When I do this I can watch the tensioner guide move back and forth, and the tensioner makes a loud clicking sound. Almost like it activates and then deactivates, you can watch it do it too.It does this at the same interval every time I rotate the crank. Is this suppose to sound like that? This is my first experiance with a tear down on this engine. Advice would be appreciated. Also help finding the colored links on the chain would be helpful as well.
 
  #2  
Old 07-16-2018, 11:37 PM
CHRYSLER TECH's Avatar
Super Moderator
Join Date: Mar 2006
Location: Norcross GA
Posts: 8,114
Default

the tensioner is spring and hydrologic they make noise untill the oil pumps it up
skip to 16 min
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
speedracer1263
Chrysler 200 & Sebring
6
08-20-2011 11:35 PM
binky42
Cirrus & Breeze
2
07-20-2011 06:10 PM
blurry
Chrysler 200 & Sebring
3
07-17-2011 07:53 AM
gbeach
Chrysler Pacifica
2
08-26-2010 12:42 PM
kgillespie
Chrysler Pacifica
2
08-13-2010 03:31 PM


Thread Tools
Search this Thread
Quick Reply: Timing question


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.