Chrysler 200 & Sebring Whether it be the sedan, coupe, or convertible, this mid-sized model offers a touch of class to every style in it's lineup

Two separate issues, fan speed dial and washer fluid.

  #1  
Old 08-13-2010, 07:29 AM
Junior Member
Thread Starter
Join Date: Aug 2010
Posts: 2
Default Two separate issues, fan speed dial and washer fluid.

I came across this forum after searching for some help..

I have a 2004 V6 Sebring Touring Edition. I bought it used last year from an old lady, and it only had 14,000km on it.

From the get go, I've had one issue, with the fan speed switch. Only speeds 3 and 4 are working, 1 and 2 provide no air at all.

The other issue is more recent, and the windshield washer fluid has stopped working. I'm not sure if it would be the fuse in the power distribution box, or the motor, or something. I *did* notice that the plastic cap on the fuse for washer fluid in the PDB is cracked, if that makes a difference.

Any help would be appreciated.

Thanks!
 
  #2  
Old 08-13-2010, 09:11 AM
dcotter0579's Avatar
Senior Member
Join Date: May 2008
Location: Detroit suburb
Posts: 4,993
Default

Why not replace the fuse and see if it works? If the fuse plastic cap is cracked, there's a very good chance that the fuse is bad.

As for the heater fan, it may be the blower resistor. That's also an easy repair. Search the forum here for that problem which is fairly common and you'll find detailed discussions on how to do it yourself. If you understand how to fix it, even if you decide to hire it done, you'll be able to discuss it intelligently with the mechanic.
 
  #3  
Old 08-13-2010, 10:28 AM
Junior Member
Thread Starter
Join Date: Aug 2010
Posts: 2
Default

Originally Posted by dcotter0579 View Post
Why not replace the fuse and see if it works? If the fuse plastic cap is cracked, there's a very good chance that the fuse is bad.

As for the heater fan, it may be the blower resistor. That's also an easy repair. Search the forum here for that problem which is fairly common and you'll find detailed discussions on how to do it yourself. If you understand how to fix it, even if you decide to hire it done, you'll be able to discuss it intelligently with the mechanic.
Thank you for your reply. Am I able to buy the fuses anywhere for the Power Distribution Box?

I've read about the blower resistor issue before, and wasn't sure if that was it. I'll have a look in the forums for more info.

Thanks again!
 
  #4  
Old 08-13-2010, 03:57 PM
dcotter0579's Avatar
Senior Member
Join Date: May 2008
Location: Detroit suburb
Posts: 4,993
Default

Any auto parts store and probably any store with a reasonable automotive section (Sears, Walmart, Kmart, etc.) will carry fuses. Pop it out and bring it to the store. Be sure to replace it with one of the proper current rating (same color).

Your owners manual will have information about replacing fuses.
 
  #5  
Old 10-28-2010, 04:35 AM
Junior Member
Join Date: Oct 2010
Posts: 2
Default

I have a similar fault on my 2.8crd.When cold only first led lights, as the engine warms the lights eventually all light up and the fan is on max, ie, cold water low fan speed, hot water maximum fan speed, anyone out there with some ideas ?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
buddy7
Chrysler 200 & Sebring
5
10-02-2011 08:46 AM
02T&CTour
Chrysler Voyager & Town & Country
0
11-10-2010 08:00 AM
jasons4
General Tech
4
12-24-2007 10:40 PM
andbudzi
General Tech
3
11-03-2007 11:07 AM
quattj
Chrysler Voyager & Town & Country
1
04-02-2007 03:29 AM


Thread Tools
Search this Thread
Quick Reply: Two separate issues, fan speed dial and washer fluid.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.