Chrysler Voyager & Town & Country The first and foremost name in minivans leading the class since their inception in the 1980s

Grinding sound when shutting off motor

  #1  
Old 10-31-2009, 04:06 PM
Junior Member
Thread Starter
Join Date: Oct 2009
Posts: 5
Default Grinding sound when shutting off motor

(04 T&C 67,000) When I shut the motor off, there is a grinding sound for about a second. I pulled off the belt tensioner and it made noise when I spun. Figured this was the culprit. Replaced that and also the idler pulley for good measure. Cranked engine, noise still there. Took screwdriver and listened to each component in the serpetine belt drive and everything sounded fine except the alternator sounded like a diesel engine. Low, grinding kind of sound. I assume the bearings are going bad. Is there any way to fix this cheap other than replace the alternator? Thanks for any advice.
 
  #2  
Old 11-05-2009, 08:54 AM
Junior Member
Thread Starter
Join Date: Oct 2009
Posts: 5
Default

Update: I went to a junk yard and found an alternator there. Put it on and that fixed the problem. I would like to replace the bearings in the old one just to have on hand. Has anyone ever changed alternator bearings before. Where would I buy them?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
TheAverageDan
Chrysler Voyager & Town & Country
7
06-02-2015 06:31 PM
fcnorwich
Chrysler Voyager & Town & Country
2
10-16-2013 02:48 AM
keyology
Chrysler 200 & Sebring
2
08-06-2009 07:39 PM
MikeM8560
Chrysler Voyager & Town & Country
1
05-13-2009 07:46 PM
joshdschwartz
Chrysler 200 & Sebring
1
02-05-2008 01:19 PM


Thread Tools
Search this Thread
Quick Reply: Grinding sound when shutting off motor


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.