hard to start when cold or hot

  #1  
Old 10-01-2007, 10:38 AM
Thread Starter
Join Date: Oct 2007
Location:
Posts: 1
Default hard to start when cold or hot

1995 Cirrus Lx 2.5L

Gentlemen and ladies,

Cold or hot, the car turns over for several seconds before starting. After it starts, it runs good. Also, shortly after starting the radiator fans come on and stay on until I shut down the engine.This happens enen though the A/C is off.I checked the ECTsensor and it is 7K ohms when cold.

Other conditions: outside temp 70 deg F., dry. Spark plugs good (some oil found in spark plug tube holes). A/C works good. Tranny is good. Coolant temp gauge on dash reads on second bar from bottom after engineis wramed up. Also. no MIL lamp, and no ECM codes (I don't know if any PCM codes exist).


Finally, when turning on the key, I can hear the fuel pump priming the injection system, but only for 1-2 seconds. Does that sound like enough time to prime before starting?

Any ideas?

TIA
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rat39
Chrysler Pacifica
5
07-17-2012 07:25 AM
travelmad
Chrysler Voyager & Town & Country
4
02-20-2012 10:29 AM
rowl3y
Chrysler Voyager & Town & Country
2
02-27-2011 10:20 AM
simonda
Chrysler Voyager & Town & Country
10
01-03-2010 02:44 PM
cheechster
Chrysler Voyager & Town & Country
0
02-07-2007 07:31 PM


Thread Tools
Search this Thread
Quick Reply: hard to start when cold or hot


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.