General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

99 LHS Ignition Issue

  #1  
Old 08-12-2008, 08:24 PM
Thread Starter
Join Date: Aug 2008
Location:
Posts: 2
Default 99 LHS Ignition Issue

About 5 months ago, my car overheated and died on the road. About 2 months ago, I decided to get it looked at. The mechanic found out that my water pump locked up and caused my timing belt to snap. We found pieces of the timing belt melted on the cam gears and all over the inside, etc....

Replacethe water pump, tensioner pulley (it was broken and ball bearings were all over the place), and the starter. Also cleaned the melted pcs oftiming belt from teh cam gears. The car is put back together as of last wk however we're running into some road blocks.

When I crank it up, the engine shakes and idles very roughly. It runs very hesitantly and slow while taking off, but whenever I get on it, it goes asgood as it used to. Once I start slowing down or stopping, it starts shaking and running roughly; almost dies. Check Engine sign indicated a P0352 error "Ignition Coil B" but AutoZone couldn't tell me what this was. Pepboys told me bunch of different things that made sense half-way.

When I unplug the ignition coil wires on the right side of the engine, nothing happens to the engine. It runs same as all wires plugged in, which points me that either all or some of the cylinders are not firing on the right side.

I don't understand how they won't fire when I start the car but then start working properly when I go fast. I assume if the right cylinders were not firing, the car would not operate like its supposed to.

I'm confused as heck. Any ideas???
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Tweaks
Chrysler PT Cruiser
3
07-09-2011 04:01 AM
kyo001
300M, Concorde, LHS, New Yorker
5
10-15-2010 02:13 PM
kyo001
300M, Concorde, LHS, New Yorker
0
10-11-2010 06:42 PM
hudd92
Chrysler Voyager & Town & Country
1
04-29-2010 10:47 AM
bigturk99lhs
300M, Concorde, LHS, New Yorker
0
08-12-2008 08:22 PM


Thread Tools
Search this Thread
Quick Reply: 99 LHS Ignition Issue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.