Loosing Coolant - Chrysler Forum - Chrysler Enthusiast Forums


Chrysler Voyager & Town & Country The first and foremost name in minivans leading the class since their inception in the 1980s
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 02-05-2018, 07:36 AM
Junior Member
Thread Starter
 
Join Date: Jan 2018
Posts: 2
Default Loosing Coolant

Hi, I have a Chrysler Voyager 2.5 CRD Diesel. Daily I need to top up coolant with approximately 3 pints. I cannot see any visible leaks. No coolant on the garage floor. The temperature gauge mostly is around the middle and occasionally goes up to the 3/4 mark. The radiator fan does not seem to switch on. The fuse / relay for the radiator fan seems fine. The oil does not look murky. What could the issue be?
Reply With Quote
  #2  
Old 02-06-2018, 04:12 PM
goggs's Avatar
Senior Member
 
Join Date: Nov 2012
Location: Dumfries....
Posts: 1,697
Default

Bleed the coolant system properly. Get the air out of the top hose/metal pipe. And check Auxiliary heater for coolant at exhaust flexi.
Reply With Quote
  #3  
Old 02-11-2018, 08:37 AM
Senior Member
 
Join Date: Feb 2014
Location: Denmark
Posts: 137
Default

The temp gauge in a CRD never goes up to 3/4 this time of the year , Max 1/2 wich is normal in summer time , in winter time it might be a little lower. "measure needle wide"

How about the coolant pipe to aux heater , Thay can be very rusty and a small leak could just evaporate weil driving .
Reply With Quote
  #4  
Old 02-11-2018, 09:10 AM
QinteQ's Avatar
Senior Member
 
Join Date: Jan 2012
Location: UK
Posts: 1,490
Default

A piece of this gives a temp fix and will move (1) the temp gauge from 1/4 to 1/2 and will shorten by 50% the driving time needed to reach that 1/2 on the gauge [can be dismantled in milliseconds] buy new stuff next winter or pop it in the boot if your middle name is Ebenezer - get the correct diameter size, you will need x3 pieces for a fully covered dam !
Reply With Quote
  #5  
Old 02-13-2018, 07:32 AM
Bee's Avatar
Bee Bee is offline
Senior Member
 
Join Date: Feb 2011
Location: South Wales
Posts: 115
Default

Hi guys.
I had this problem for about 18 months I disconected the Aux heater and I've had no trouble since. But I will say it was a bit of a pig to blead the system.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
steering gear loosing fluid right side latreto Chrysler Voyager & Town & Country 1 05-20-2012 07:34 PM
Concorde loosing coolant chrycon 300M, Concorde, LHS, New Yorker 0 10-16-2010 10:25 AM
loosing lots of cooling when car is runing.. jquinones Chrysler Voyager & Town & Country 1 12-04-2008 02:54 PM
04 Pacifica 3.5L engine loosing power at road speed shadetreemech General Tech 0 04-12-2008 10:08 AM
loosing coolant fibersport Chrysler Voyager & Town & Country 4 02-07-2008 02:02 AM


Tags
coolants, radiator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 07:39 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.